Click or drag to resize

GH_ScrollBarVerticalBase Class

Provides basic vertical scroll bar logic.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.BaseGH_ScrollBarVerticalBase

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ScrollBarVerticalBase

The GH_ScrollBarVerticalBase type exposes the following members.

Constructors
  NameDescription
Public methodGH_ScrollBarVerticalBase
Initializes a new instance of the GH_ScrollBarVerticalBase class
Top
Properties
  NameDescription
Public propertyContent
Gets or sets the height of the content
Public propertyContentOffset
Gets the vertical offset (in pixels) of the scrolled content.
Public propertyDisplay
Gets or sets the height of the display area.
Public propertyMinimum
Gets or sets the minimum height of the scrollbar.
Public propertyOffset
Gets the offset of the scroller.
Public propertyOffsetNormalised
Gets or sets the normalised offset of the scroller.
Top
Methods
  NameDescription
Public methodBeginDrag
Start a new drag operation.
Public methodContinueDrag
Continue a drag operation.
Public methodScrollBar(Rectangle)
Compute the size and position of the scroll bar in the scroll rail.
Public methodScrollBar(RectangleF)
Compute the size and position of the scroll bar in the scroll rail.
Top
See Also