Click or drag to resize

IGH_ResponsiveObject Interface

If you wish to participate in Canvas UI events, you must implement this interface.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_ResponsiveObject

The IGH_ResponsiveObject type exposes the following members.

Methods
  NameDescription
Public methodRespondToKeyDown
Public methodRespondToKeyUp
Public methodRespondToMouseDoubleClick
This function will be called whenever the left button is double-clicked over the canvas. If you are active, you will be the only object who gets called.
Public methodRespondToMouseDown
This function will be called whenever a mouse button is pressed over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.
Public methodRespondToMouseMove
This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.
Public methodRespondToMouseUp
This function will be called whenever a mouse button is released over the canvas. If you are active, you will be the only object who gets called. If you are inactive, you will not be called at all for MouseUp events.
Top
See Also