Click or drag to resize

IGH_ResponsiveObjectRespondToMouseMove Method

This function will be called when the mouse moves across the canvas. If you are active, you will be the only object who gets called. If you are inactive, you might get called if nobody on top of you decides to become active.

Namespace:  Grasshopper.GUI.Canvas
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
GH_ObjectResponse RespondToMouseMove(
	GH_Canvas sender,
	GH_CanvasMouseEvent e
)

Parameters

sender
Type: Grasshopper.GUI.CanvasGH_Canvas
Base canvas.
e
Type: Grasshopper.GUIGH_CanvasMouseEvent
Mouse event arguments.

Return Value

Type: GH_ObjectResponse
All Response flags are valid.
See Also