Click or drag to resize

GH_DragInfo Class

Contains data used for UI drag operations.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUIGH_DragInfo

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_DragInfo

The GH_DragInfo type exposes the following members.

Constructors
  NameDescription
Public methodGH_DragInfo
Create a new DragInfo instance.
Top
Properties
  NameDescription
Public propertyBox_Drag
Gets the dimensions of the box as a result of the dragging op.
Public propertyBox_Start
Gets the dimensions of the drag box prior to dragging.
Public propertyConstraint
Gets or sets the directional constraint for the drag operation.
Public propertyPoint_Drag
Gets the cursor location at the current moment.
Public propertyPoint_Start
Gets the cursor location at the start of the drag.
Public propertyRegion
Gets or sets the drag limits. If the region is Rectangle.Empty then the region is ignored. For valid results the Region should be larger than the dimensions of the drag box.
Top
Methods
  NameDescription
Public methodDrag
Call this method to adjust the drag data. Results will be automatically constrained and limited.
Top
See Also