Click or drag to resize

GH_Slider_Obsolete Class

General purpose numeric slider.
Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Slider_Obsolete : UserControl

The GH_Slider_Obsolete type exposes the following members.

Constructors
  NameDescription
Public methodGH_Slider_Obsolete
Initializes a new instance of the GH_Slider_Obsolete class
Top
Properties
  NameDescription
Public propertyDisplayFormat
Gets or sets the display format fo the slider. This is the formatting that is applied prior to drawing. The default is {0} which results in a 1:1 display. Use this to append units or symbols.
Public propertyDrawRail
Gets or sets a flag that control whether or not grip rails are drawn.
Public propertyGripBackColor
Background colour of slider grip.
Public propertyGripForeColor
Foreground colour of slider grip.
Public propertyIsIntermediate
Gets the intermediate flag. If True, the user is currently dragging the slider.
Public propertyMax
Gets or sets the maximum allowed value.
Public propertyMin
Gets or sets the minimum allowed value.
Public propertyNumericFormat
Gets or sets the numeric format for the slider. This is the formatting that is applied to the number. The default is #0.00 which results in a two digit rounding scheme.
Public propertyTextInputMode
Gets or sets the Text input mode for this slider.
Public propertyTickFrequency
Gets or sets the tick frequency of the slider.
Public propertyValue
Gets or sets the current value.
Public propertyValueF
Gets or sets the current value in single-floating-point precision.
Top
Methods
Events
  NameDescription
Public eventValueChanged
Raised whenever the value of the slider is changed via GUI interaction.
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also