Click or drag to resize

GH_AssemblyInfo Class

Implement this interface once (and once only) in a GHA project if you wish to add additional information about your library to Grasshopper. Note you must supply an empty constructor.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class GH_AssemblyInfo

The GH_AssemblyInfo type exposes the following members.

Constructors
  NameDescription
Protected methodGH_AssemblyInfo
Initializes a new instance of the GH_AssemblyInfo class
Top
Properties
  NameDescription
Public propertyAssembly
Gets the actual assembly that this info object describes.
Public propertyAuthorContact
Gets the contact information for the author. This can be email, phone, fax, address or all of the above. Return null if you do not wish to associate contact details with this assembly.
Public propertyAuthorName
Gets the name of the individual/company/organisation that is responsible for this assembly. Return null if you do not wish to associate an author with this assembly.
Public propertyDescription
Gets the human readable description of this assembly. Return null if you do not wish to associate a description with this assembly.
Public propertyIcon
Gets a 24x24 icon that represents this assembly. Return null if you do not wish to associate an icon with this assembly.
Public propertyId
Gets the Id of this assembly. By default the Id is a hash of the name.
Public propertyIsCoreLibrary
Gets whether this library is a Grasshopper core library. Core libraries are installed along with Grasshopper and thus should always be available anywhere.
Public propertyLicense
Gets the license type for this assembly.
Public propertyLoadingMechanism
Gets the mechanism used to load this assembly.
Public propertyLocation
Gets the location this assembly was loaded from.
Public propertyName
Gets the human readable name of this assembly. Return null if you do not wish to associate a name with this assembly.
Public propertyVersion
Gets the version code for this assembly.
Top
See Also