Click or drag to resize

GH_BakeUtility Class

A utility class for baking. We heavily recommend you use this for any baking, as it handles invalid objects correctly.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_BakeUtility

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_BakeUtility

The GH_BakeUtility type exposes the following members.

Constructors
  NameDescription
Public methodGH_BakeUtility
Create a new baker.
Top
Properties
  NameDescription
Public propertyBakedCount
Gets the number of successful baking operations.
Public propertyBakedIds
Gets all collected object ids.
Public propertyInvalidCount
Gets the number of invalid objects encountered.
Top
Methods
  NameDescription
Public methodBakeObject
Try and bake a single object.
Public methodBakeObjects
Bake a bunch of objects.
Top
See Also