Click or drag to resize

GH_FileSystemEventServer Class

Provides a easy-to-use way to keep tabs on files.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_FileSystemEventServer

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_FileSystemEventServer

The GH_FileSystemEventServer type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberAllPaths
Gets a list of all the paths currently under surveillance.
Top
Methods
  NameDescription
Public methodStatic memberAddWatcher
Add a new file watcher instance.
Public methodStatic memberRemoveWatcher(Object)
Remove all watchers that are linked to a specific object.
Public methodStatic memberRemoveWatcher(Object, String)
Remove all watchers that are linked to a specific object and a specific file path.
Top
See Also