Click or drag to resize

GH_FileSystemEventServerAddWatcher Method

Add a new file watcher instance.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static void AddWatcher(
	Object owner,
	string path,
	GH_FileSystemEventServerFileEvent callback
)

Parameters

owner
Type: SystemObject
The object that owns this watcher.
path
Type: SystemString
The path of the file to watch.
callback
Type: Grasshopper.KernelGH_FileSystemEventServerFileEvent
Callback delegate used during file changes.
See Also