Click or drag to resize

GH_PreviewUtil Class

This class exposes functionality that makes it easy to draw temporary geometry in Rhino viewports.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_PreviewUtil

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_PreviewUtil : IDisposable

The GH_PreviewUtil type exposes the following members.

Constructors
  NameDescription
Public methodGH_PreviewUtil
Initializes a new instance of the GH_PreviewUtil class
Public methodGH_PreviewUtil(Boolean)
Initializes a new instance of the GH_PreviewUtil class
Top
Properties
  NameDescription
Public propertyEnabled
Gets or sets the enabled state of this Preview util.
Public propertyWireColour
Gets or sets the colour to use for Preview geometry.
Top
Methods
  NameDescription
Public methodAddBox
Add a box to the temporary Preview lists.
Public methodAddBrep
Add a brep to the temporary Preview lists.
Public methodAddCurve
Add a curve to the temporary Preview lists.
Public methodAddLine
Add a line to the temporary Preview lists.
Public methodAddMesh
Add a mesh to the temporary Preview lists.
Public methodAddPlane
Add a plane to the temporary Preview lists.
Public methodAddPoint
Add a point to the temporary Preview lists.
Public methodAddVector
Add a vector to the temporary Preview lists.
Public methodClear
Clear all temporary geometry.
Public methodDispose
Releases all resources used by the GH_PreviewUtil
Public methodRedraw
Forces a redraw the the viewports.
Top
See Also