Click or drag to resize

GH_State Class

Represents a single recorded document state. A state contains values for an arbitrary set of objects inside the document.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_State

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_State : GH_ISerializable

The GH_State type exposes the following members.

Constructors
  NameDescription
Public methodGH_State
Initializes a new instance of the GH_State class
Public methodGH_State(GH_State)
Initializes a new instance of the GH_State class
Top
Properties
  NameDescription
Public propertyDataGuid
Gets the state data stored under the specified ID
Public propertyDataInt32
Gets the state data stored under the specified index
Public propertyLastModified
Gets the date at which this state was last modified.
Public propertyName
Gets or sets the name of this state.
Public propertyStateCount
Gets the number of items stored in the state database.
Public propertyStateData
Gets a pointer to the internal database of states.
Top
Methods
  NameDescription
Public methodAddStateObject
Append a new object to the database.
Public methodClearStates
Removes all items from the state database.
Public methodCreateStateFromDocument
Creates a state database from a document.
Public methodRead
Public methodRemoveStateObject
Remove an object from the database.
Public methodWrite
Top
See Also