Click or drag to resize

GH_ComplexNumber Class

Wraps up the Complex data type for IGH_Goo adherence.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooComplex
    Grasshopper.Kernel.TypesGH_ComplexNumber

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ComplexNumber : GH_Goo<Complex>

The GH_ComplexNumber type exposes the following members.

Constructors
  NameDescription
Public methodGH_ComplexNumber
Blank constructor
Public methodGH_ComplexNumber(Complex)
Initializes a new instance of the GH_ComplexNumber class
Public methodGH_ComplexNumber(GH_ComplexNumber)
Initializes a new instance of the GH_ComplexNumber class
Top
Properties
  NameDescription
Public propertyIsValid
Gets the validity of this instance. If either the real or the imaginary component are NaN, then it is considered invalid
(Overrides GH_GooTIsValid.)
Public propertyIsValidWhyNot
Gets a string describing the state of "invalidness". If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.)
Public propertyTypeDescription (Overrides GH_GooTTypeDescription.)
Public propertyTypeName (Overrides GH_GooTTypeName.)
Top
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateComplex
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also