Click or drag to resize

Complex Structure

Complex number type in Grasshopper. Do not confuse with GH_Complex which is the IGH_Goo implementation of ComplexNumber.

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public struct Complex

The Complex type exposes the following members.

Constructors
  NameDescription
Public methodComplex(Double)
Initializes a new instance of the Complex class
Public methodComplex(Double, Double)
Initializes a new instance of the Complex class
Top
Properties
  NameDescription
Public propertyArgument
Gets or sets the complex argument.
Public propertyStatic memberComplexUnit
Public propertyImaginary
Gets or sets the imaginary component of the Complex number.
Public propertyStatic memberInfinity
Public propertyIsReal
Gets whether this complex number only has a real component.
Public propertyIsRealNonNegative
Gets whether this complex number only has a positive real component.
Public propertyIsValid
Gets the validity of this number.
Public propertyIsZero
Gets whether or not this complex number equals {0.0; 0.0}
Public propertyStatic memberNaN
Public propertyStatic memberNegativeInfinity
Public propertyReal
Gets or sets the real component of the Complex number.
Public propertyStatic memberZero
Top
Methods
Operators
See Also