Click or drag to resize

GH_Guid Class

Represents a globally unique identifier. GH_Guid re-implements the framework System.Guid type.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_GooGuid
    Grasshopper.Kernel.TypesGH_Guid

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_Guid : GH_Goo<Guid>

The GH_Guid type exposes the following members.

Constructors
  NameDescription
Public methodGH_Guid
Blank constructor
Public methodGH_Guid(GH_Guid)
Initializes a new instance of the GH_Guid class
Public methodGH_Guid(Guid)
Initializes a new instance of the GH_Guid class
Top
Properties
Methods
  NameDescription
Public methodCastFrom (Overrides GH_GooTCastFrom(Object).)
Public methodCastToT(T) (Overrides GH_GooTCastToQ(Q).)
Public methodDuplicate (Overrides GH_GooTDuplicate.)
Public methodDuplicateGuid
Public methodEmitProxy (Overrides GH_GooTEmitProxy.)
Public methodRead (Overrides GH_GooTRead(GH_IReader).)
Public methodToString (Overrides GH_GooTToString.)
Public methodWrite (Overrides GH_GooTWrite(GH_IWriter).)
Top
Fields
See Also