GH_Interval2D Class |
Namespace: Grasshopper.Kernel.Types
The GH_Interval2D type exposes the following members.
Name | Description | |
---|---|---|
GH_Interval2D |
Default constructor. Creates two empty intervals.
| |
GH_Interval2D(GH_Interval2D) |
Create a duplicate of another two-dimensional interval
| |
GH_Interval2D(UVInterval) |
Duplicates a one-dimensional interval in both directions.
|
Name | Description | |
---|---|---|
IsValid |
Gets the validity of this instance. Valid intervals contain no #NaN extremes
(Overrides GH_GooTIsValid.) | |
IsValidWhyNot |
Gets a string describing the state of "invalidness".
If the instance is valid, then this property should return Nothing or String.Empty.
(Overrides GH_GooTIsValidWhyNot.) | |
TypeDescription | (Overrides GH_GooTTypeDescription.) | |
TypeName | (Overrides GH_GooTTypeName.) | |
Value |
Gets or sets the internal data.
(Inherited from GH_GooT.) |
Name | Description | |
---|---|---|
CastFrom |
Remote to Local caster function. This stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastFrom(Object).) | |
CastToQ(Q) |
Attempt a cast to type Q.
(Inherited from GH_GooT.) | |
CastToT(T) |
Local to Remote caster function. this stuff is complex, don't concern yourself with casting logic.
(Overrides GH_GooTCastToQ(Q).) | |
Duplicate |
Create a duplicate of this interval.
(Overrides GH_GooTDuplicate.) | |
DuplicateInterval |
Create a duplicate of this interval.
| |
EmitProxy |
Returns a proxy that represents this interval. Do not call this function unless you're
(Overrides GH_GooTEmitProxy.) | |
Read | (Overrides GH_GooTRead(GH_IReader).) | |
ScriptVariable |
This function will be called when the local IGH_Goo instance
disappears into a user Script. This would be an excellent place to
cast your IGH_Goo type to a simple data type.
(Inherited from GH_GooT.) | |
ToString |
Format the interval using default grasshopper formatting logic.
(Overrides GH_GooTToString.) | |
Write | (Overrides GH_GooTWrite(GH_IWriter).) |