Click or drag to resize

GH_PointRefData Class

Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.TypesGH_PointRefData

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PointRefData

The GH_PointRefData type exposes the following members.

Constructors
  NameDescription
Public methodGH_PointRefData
Initializes a new instance of the GH_PointRefData class
Public methodGH_PointRefData(GH_PointRefData)
Initializes a new instance of the GH_PointRefData class
Top
Methods
  NameDescription
Public methodEvCurve
Evaluate this reference structure when applied to a curve
Public methodEvCurveParam
Evaluate this reference structure when applied to a curve
Public methodEvSurface
Evaluate this reference structure when applied to the surface
Protected methodSetCurveDistFromEndParam
Protected methodSetCurveDistFromStartParam
Public methodSetCurveParam
Set the curve reference parameter based on the value of m_RefType and the curve parameter
Protected methodSetCurveRatioParam
Public methodSetSurfaceParam
Set the surface reference parameters
Top
Fields
See Also