Click or drag to resize

ModelInstanceDefinition Class

Represents a Rhino block definition. Wraps the functionality of the InstanceDefinition type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Model
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class ModelInstanceDefinition : ModelComponentContent, 
	IGH_BakeAwareData, IGH_PreviewData

The ModelInstanceDefinition type exposes the following members.

Constructors
  NameDescription
Public methodModelInstanceDefinition
Initializes a new instance of the ModelInstanceDefinition class
Public methodModelInstanceDefinition(ModelInstanceDefinitionAttributes)
Initializes a new instance of the ModelInstanceDefinition class
Public methodModelInstanceDefinition(Guid)
Initializes a new instance of the ModelInstanceDefinition class
Public methodModelInstanceDefinition(InstanceDefinition)
Initializes a new instance of the ModelInstanceDefinition class
Top
Properties
Methods
Operators
See Also