Click or drag to resize

ModelLayer Class

Represents a Rhino model layer. Wraps the functionality of the Layer type.
Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Model
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class ModelLayer : ModelComponentContent, 
	IGH_BakeAwareData

The ModelLayer type exposes the following members.

Constructors
  NameDescription
Public methodModelLayer
Initializes a new instance of the ModelLayer class
Public methodModelLayer(ModelLayerAttributes)
Initializes a new instance of the ModelLayer class
Public methodModelLayer(Guid)
Initializes a new instance of the ModelLayer class
Public methodModelLayer(Layer)
Initializes a new instance of the ModelLayer class
Top
Properties
  NameDescription
Public propertyDisplayColor
Public propertyDraftingColor
Public propertyHidden
Public propertyHiddenOnModel
Public propertyHiddenOnNewDetail
Public propertyLinetype
Public propertyLineWeight
Public propertyLocked
Public propertyMaterial
Public propertyStatic memberUnset
Top
Methods
Operators
See Also