ModelRenderEnvironment Class |
Namespace: Grasshopper.Rhinoceros.Render
The ModelRenderEnvironment type exposes the following members.
Name | Description | |
---|---|---|
ModelRenderEnvironment | Initializes a new instance of the ModelRenderEnvironment class | |
ModelRenderEnvironment(ModelRenderEnvironmentAttributes) | Initializes a new instance of the ModelRenderEnvironment class | |
ModelRenderEnvironment(Guid) | Initializes a new instance of the ModelRenderEnvironment class | |
ModelRenderEnvironment(RenderEnvironment) | Initializes a new instance of the ModelRenderEnvironment class |
Name | Description | |
---|---|---|
TypeName | (Overrides ModelRenderContentTypeName.) |
Name | Description | |
---|---|---|
Cast | ||
CastToT(T) | (Overrides ModelContentCastToT(T).) | |
ToAttributes | ||
Name | Description | |
---|---|---|
(ModelRenderEnvironmentAttributes to ModelRenderEnvironment) | ||
(ColorRGBA to ModelRenderEnvironment) | ||
(RenderEnvironment to ModelRenderEnvironment) | ||
(String to ModelRenderEnvironment) |