Description:

Get neighbors.

Syntax:
protected virtual GripObject NeighborGrip(
int gripIndex,
int dr,
int ds,
int dt,
bool wrap
)
protected
virtual
Parameters:
  • gripIndex
  • Type: int
  • index of grip where the search begins.
  • dr
  • Type: int
  • 1 = next grip in the first parameter direction. -1 = previous grip in the first parameter direction.
  • ds
  • Type: int
  • 1 = next grip in the second parameter direction. -1 = previous grip in the second parameter direction.
  • dt
  • Type: int
  • 1 = next grip in the third parameter direction. -1 = rev grip in the third parameter direction.
  • wrap
  • Type: bool
  • If True and object is "closed", the search will wrap.
Returns:
Pointer to the desired neighbor or NULL if there is no neighbor.

Nothing found