Description:

Modify material settings.

Syntax:
public bool Modify(
Material newSettings,
int materialIndex,
bool quiet
)
Parameters:
  • newSettings
  • Type: Material
  • This information is copied.
  • materialIndex
  • Type: int
  • zero based index of material to set. This must be in the range 0 <= layerIndex < MaterialTable.Count.
  • quiet
  • Type: bool
  • if true, information message boxes pop up when illegal changes are attempted.
Returns:
Type: bool
True if successful. False if materialIndex is out of range or the settings attempt to lock or hide the current material.
Available since:
5.0

Nothing found