Description:

Uses the name to find a model component. The name is the value that is stored in the .Name property. Deleted objects have no name.

Syntax:
public abstract ModelComponent FindName(
string name,
ModelComponentType type,
Guid parent
)
Parameters:
  • name
  • Type: string
  • Name of model component to search for.
  • parent
  • Type: System.Guid
  • Parent object id. This is only required for layers.
Returns:
Reference to the rhino object or None if no such object could be found.
Available since:
6.0

Description:

Uses the name to find a model component. The name is the value that is stored in the .Name property. Deleted objects have no name.

Syntax:
public T FindName(
string name,
Guid parent
)
Parameters:
  • name
  • Type: string
  • Name of model component to search for.
  • parent
  • Type: System.Guid
  • Parent object id. This is only required for layers.
Returns:
Type: T
Reference to the rhino object or None if no such object could be found.
Available since:
6.0

Nothing found