Description:

Uses the hash of the name to find a model component. Deleted objects have no name.

Syntax:
public abstract ModelComponent FindNameHash(
NameHash nameHash,
ModelComponentType type
)
Parameters:
  • nameHash
  • Type: NameHash
  • NameHash of model component to search for.
Returns:
Reference to the rhino object or None if no such object could be found.
Available since:
6.0

Description:

Uses the hash of the name to find a model component. Deleted objects have no name.

Syntax:
public T FindNameHash(
NameHash nameHash
)
Parameters:
  • nameHash
  • Type: NameHash
  • Name hash of model component to search for.
Returns:
Type: T
Available since:
6.0

FindNameHash method

Class:  Rhino.FileIO.ManifestTable

Nothing found