Namespace: Rhino.PlugInsLicenseUtils: references
LicenseUtils()
AskUserForLicense(int productType, bool standAlone, object parentWindow, string textMask, ValidateProductKeyDelegate validateProductKeyDelegate, OnLeaseChangedDelegate onLeaseChangedDelegate, string product_path, string product_title,Guid pluginId,Guid licenseId, LicenseCapabilities capabilities)
AskUserForLicense(int productType, bool standAlone, object parentWindow, string textMask, ValidateProductKeyDelegate validateProductKeyDelegate, OnLeaseChangedDelegate onLeaseChangedDelegate, VerifyLicenseKeyDelegate verifyLicenseKeyDelegate, VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate, string product_path, string product_title,Guid pluginId,Guid licenseId, LicenseCapabilities capabilities)
CheckInLicense(Guid productId)
CheckOutLicense(Guid productId)
ConvertLicense(Guid productId)
DeleteLicense(Guid productId)
Echo(string message)
GetLicense(ValidateProductKeyDelegate validateProductKeyDelegate, OnLeaseChangedDelegate leaseChangedDelegate, int product_type, int capabilities, string textMask, string product_path, string product_title,Guid pluginId,Guid licenseId)
GetLicense(ValidateProductKeyDelegate validateProductKeyDelegate, OnLeaseChangedDelegate leaseChangedDelegate, VerifyLicenseKeyDelegate verifyLicenseKeyDelegate, VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate, int product_type, int capabilities, string textMask, string product_path, string product_title,Guid pluginId,Guid licenseId)
GetLicenseCapabilities(int filter)
GetLicenseStatus()
GetLicenseType(Guid productId)
GetOneLicenseStatus(Guid productid)
Initialize()
IsCheckOutEnabled()
LicenseOptionsHandler(Guid pluginId,Guid licenseId, string productTitle, bool standAlone)
LoginToCloudZoo()
LogoutOfCloudZoo()
ReturnLicense(Guid productId)
ShowBuyLicenseUi(Guid productId)
ShowLicenseValidationUi(string cdkey)
ShowRhinoExpiredMessage(Mode mode, ref int result)