Description:
This version of Rhino.PlugIns.LicenseUtils.AskUserForLicense is used by Rhino C++ plug-ins.
Syntax:
public static bool AskUserForLicense(
int productType,
bool standAlone,
object parentWindow,
string textMask,
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate onLeaseChangedDelegate,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId,
LicenseCapabilities capabilities
)
int productType,
bool standAlone,
object parentWindow,
string textMask,
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate onLeaseChangedDelegate,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId,
LicenseCapabilities capabilities
)
Description:
Syntax:
public static bool AskUserForLicense(
int productType,
bool standAlone,
object parentWindow,
string textMask,
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate onLeaseChangedDelegate,
VerifyLicenseKeyDelegate verifyLicenseKeyDelegate,
VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId,
LicenseCapabilities capabilities
)
int productType,
bool standAlone,
object parentWindow,
string textMask,
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate onLeaseChangedDelegate,
VerifyLicenseKeyDelegate verifyLicenseKeyDelegate,
VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId,
LicenseCapabilities capabilities
)