Description:
This version of Rhino.PlugIns.LicenseUtils.GetLicense is used by Rhino C++ plug-ins.
Syntax:
public static bool GetLicense(
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate leaseChangedDelegate,
int product_type,
int capabilities,
string textMask,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId
)
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate leaseChangedDelegate,
int product_type,
int capabilities,
string textMask,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId
)
Description:
Syntax:
public static bool GetLicense(
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate leaseChangedDelegate,
VerifyLicenseKeyDelegate verifyLicenseKeyDelegate,
VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate,
int product_type,
int capabilities,
string textMask,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId
)
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate leaseChangedDelegate,
VerifyLicenseKeyDelegate verifyLicenseKeyDelegate,
VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate,
int product_type,
int capabilities,
string textMask,
string product_path,
string product_title,
Guid pluginId,
Guid licenseId
)