Description:
ZooClientParameters Constructor
Syntax:
public ZooClientParameters(
Guid productGuid,
Guid licenseGuid,
string productTitle,
int productBuildType,
LicenseCapabilities capabilities,
string licenseEntryTextMask,
string productPath,
object parentWindow,
LicenseTypes selectedLicenseType,
ValidateProductKeyDelegate validateProductKey,
OnLeaseChangedDelegate onLeaseChangedDelegate,
VerifyLicenseKeyDelegate verifyLicenseKeyDelegate,
VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate
)
Guid productGuid,
Guid licenseGuid,
string productTitle,
int productBuildType,
LicenseCapabilities capabilities,
string licenseEntryTextMask,
string productPath,
object parentWindow,
LicenseTypes selectedLicenseType,
ValidateProductKeyDelegate validateProductKey,
OnLeaseChangedDelegate onLeaseChangedDelegate,
VerifyLicenseKeyDelegate verifyLicenseKeyDelegate,
VerifyPreviousVersionLicenseDelegate verifyPreviousVersionLicenseKeyDelegate
)
Parameters:
- productGuid
- Type: System.Guid
- Guid used by ZooClient to identify the plug-in requesting a license from ZooClient. This Guid may be used by different versions of the plug-in. If different licenses are used by different versions of the plug-in, the plug-in must also specify a LicenseGuid.
- licenseGuid
- Type: System.Guid
- Guid used by ZooClient to identify the license saved by ZooClient. This differs from ProductGuid because different versions of a plug-in with the same Plug-in ID may need different licenses.
- productTitle
- Type: string
- Title of product displayed in user interface
- productBuildType
- Type: int
- capabilities
- Type: LicenseCapabilities
- Enum that declares whether this product supports evalation, licensing, purchasing, and cloud zoo
- licenseEntryTextMask
- Type: string
- Text mask used to limit input. EG: RH50-AAAA-AAAA-AAAA-AAAA-AAAA
- productPath
- Type: string
- Full path to DLL implementing product
- parentWindow
- Type: object
- Object used to parent UI DLLs
- selectedLicenseType
- Type: LicenseTypes
- Type of license currently used by this product
- validateProductKey
- Type: ValidateProductKeyDelegate
- Delegate called to validate the structure of a license key
- onLeaseChangedDelegate
- Type: OnLeaseChangedDelegate
- Delegate called when a cloud zoo lease changes
- verifyLicenseKeyDelegate
- Type: VerifyLicenseKeyDelegate
- Delegate called to verify the structure of a license key
- verifyPreviousVersionLicenseKeyDelegate
- Type: VerifyPreviousVersionLicenseDelegate
- Delegate called to verify the structure of an upgrade license key
Available since:
6.0