ExePlatform

Returns the platform of the Rhino executable.

Syntax

Rhino.ExePlatform ()

Parameters

None.

Returns

Number

The Rhino platform if successful. Possible values are as follows:

Value

Description

0

32-Bit Rhino (x86)

1

64-bit Rhino (x64)

Null

If not successful, or on error.

Example

If Rhino.ExePlatform() = 1 Then

  Call Rhino.Print("You are using a 64-bit version of Rhino.")

Else

  Call Rhino.Print("You are using a 32-bit version of Rhino.")

End If

Also See

BuildDate

ExeVersion

InstallType

NodeType

SdkServiceRelease

SdkVersion

SerialNumber