InstallType

Returns the license installation type of this Rhino executable.  The license installation types are as follows:

Value

Description

0

Undefined license

1

Commercial license

2

Educational license

3

Educational Lab license

4

Not For Resale (NFR) license

5

Not For Resale (NFR) Lab license

6

Beta license

7

Beta Lab license

8

Evaluation license

9

Corporate license

10

Evaluation license (time-based)

Syntax

Rhino.InstallType ()

Parameters

None.

Returns

Number

The Rhino license installation type if successful.

Null

If not successful, or on error.

Example

Rhino.Print "Build date:" & CStr(Rhino.BuildDate)

Rhino.Print "SDK Version:" & CStr(Rhino.SdkVersion)

Rhino.Print "SDK Service Release:" & CStr(Rhino.SdkServiceRelease)

Rhino.Print "Executable Version:" & CStr(Rhino.ExeVersion)

Rhino.Print "Executable Service Release:" & CStr(Rhino.ExeServiceRelease)

Rhino.Print "Serial Number:" & Rhino.SerialNumber

Rhino.Print "Node Type:" & CStr(Rhino.NodeType)

Rhino.Print "Install Type:" & CStr(Rhino.InstallType)

Also See

BuildDate

ExeServiceRelease

ExeVersion

InstallType

NodeType

SdkServiceRelease

SdkVersion

SerialNumber