DimStyleScale

Returns or modifies the scale of a dimension style.

Syntax

Rhino.DimStyleScale (strDimStyle [, dblScale])

Parameters

strDimStyle

Required.  String.  The name of an existing dimension style.

dblScale

Optional.  Number.  The new scale value.  If omitted, the scale is returned.

Returns

Number

If a scale is not specified, the current scale if successful.

Number

If a scale is specified, the previous scale if successful.

Null

If not successful, or on error.

Example

Dim strDimStyle, dblScale

strDimStyle = Rhino.CurrentDimStyle

dblScale = Rhino.DimStyleScale(strDimStyle)

If dblScale > 1 Then

Rhino.DimStyleScale strDimStyle, 1

End If

Also See

DimStyleAnglePrecision

DimStyleArrowSize

DimStyleExtension

DimStyleFont

DimStyleNumberFormat

DimStyleOffset

DimStyleTextAlignment

DimStyleTextHeight