UnitAbsoluteTolerance

Returns or sets the document's absolute tolerance parameter.  Absolute tolerance is measured in drawing units. See Rhino's DocumentProperties command (Units and Page Units windows) for details.

Syntax

Rhino.UnitAbsoluteTolerance ([dblAbsTol [, blnModelUnits]])

Parameters

dblAbsTol

Optional.  Number.  The absolute tolerance in drawing units.

blnModelUnits

Optional.  Boolean.  Return or modify the document's model units (True) or the document's page units (False). The default is True.

Returns

Number

If dblAbsTol is not specified, the current absolute tolerance if successful.

Number

If dblAbsTol is specified, the previous absolute tolerance if successful.

Null

If not successful, or on error.

Example

Dim dblAbsTol

dblAbsTol = Rhino.UnitAbsoluteTolerance

If dblAbsTol < 0.01 Then

Rhino.UnitAbsoluteTolerance 0.01

End If

Also See

UnitAngleTolerance

UnitCustomUnitSystem

UnitDistanceDisplayMode

UnitDistanceDisplayPrecision

UnitRelativeTolerance

UnitSystem