Returns or sets the document's distance display mode parameter. See Rhino's DocumentProperties command (Units and Page Units windows) for details.
Rhino.UnitDistanceDisplayMode ([intMode [, blnModelUnits]])
intMode |
Optional. Number. The distance display mode. The available distance display modes are as follows:
|
||||||||
blnModelUnits |
Optional. Boolean. Return or modify the document's model units (True) or the document's page units (False). The default is True. |
Number |
If intMode is not specified, the current distance display mode if successful. |
Number |
If intMode is specified, the previous distance display mode if successful. |
Null |
If not successful, or on error. |
Const rhUnitInches = 8
Const rhUnitDistanceDisplayFeetInches = 2
Dim intUnitSystem
intUnitSystem = Rhino.UnitSystem
If intUnitSystem = rhUnitInches Then
Rhino.UnitDistanceDisplayMode rhUnitDistanceDisplayFeetInches
End If