UnitDistanceDisplayPrecision

Returns or sets the document's distance display precision parameter.  See Rhino's DocumentProperties command (Units and Page Units windows) for details.

Syntax

Rhino.UnitDistanceDisplayPrecision ([intPrecision [, blnModelUnits]])

Parameters

intPrecision

Optional.  Number.  The distance display precision.  If the current distance display mode is Decimal, then intPrecision is the number of decimal places.  If the current distance display mode is Fractional (including Feet and Inches), then the denominator = (1/2)^intPrecision.  Use UnitDistanceDisplayMode to get the current distance display mode.

blnModelUnits

Optional.  Boolean.  Return or modify the document's model units (True) or the document's page units (False). The default is True.

Returns

Number

If intPrecision is not specified, the current distance display precision if successful.

Number

If intPrecision is specified, the previous distance display precision if successful.

Null

If not successful, or on error.

Example

Dim intPrecison

intPrecision = 3

Rhino.UnitDistanceDisplayPrecision intPrecision

Also See

UnitAbsoluteTolerance

UnitAngleTolerance

UnitCustomUnitSystem

UnitDistanceDisplayMode

UnitRelativeTolerance

UnitSystem