Returns the identifiers of objects based on the objects' color. Object colors are represented as RGB colors. An RGB color specifies the relative intensity of red, green, and blue to cause a specific color to be displayed.
Rhino.ObjectsByColor (lngColor [, blnSelect [, intType]])
lngColor |
Required. Number. An RGB color value. |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
blnSelect |
Optional. Boolean. Select the objects. If omitted, the objects are not selected (False). |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
intType |
Optional. Number. The type(s) of geometry objects (points, curves, surfaces, meshes, etc.) that can be returned. Object types can be added together to filter several different kinds of geometry.
|
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strObject, lngColor
strObject = Rhino.GetObject("Pick any object")
If Not IsNull(strObject) Then
lngColor = Rhino.ObjectColor(strObject)
arrObjects = Rhino.ObjectsByColor(lngColor, True)
End If