Returns the identifiers of objects based on the objects' user-assigned URL.
Rhino.ObjectsByURL (strURL [, blnSelect [, intType]])
strURL |
Required. String. The URL of an object or objects. |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
blnSelect |
Optional. Boolean. Select the objects. If omitted, the objects are not selected (False). |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
intType |
Optional. Number. The type(s) of geometry objects (points, curves, surfaces, meshes, etc.) that can be returned. Object types can be added together to filter several different kinds of geometry.
|
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strURL
strURL = Rhino.GetString("URL to select")
If Not IsNull(strURL) Then
arrObjects = Rhino.ObjectsByURL(strURL, True)
End If