Returns the identifiers of objects based on the objects' group name.
Rhino.ObjectsByGroup (strGroup [, blnSelect [, intType]])
strGroup |
Required. String. The name of a group of objects. |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
blnSelect |
Optional. Boolean. Select the objects. If omitted, the objects are not selected (False). |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
intType |
Optional. Number. The type(s) of geometry objects (points, curves, surfaces, meshes, etc.) that can be returned. Object types can be added together to filter several different kinds of geometry.
|
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strGroup
strGroup = Rhino.GetString("Group to select")
If Not IsNull(strGroup) Then
arrObjects = Rhino.ObjectsByGroup(strGroup, True)
End If