Returns the identifiers of objects based on the objects' user-assigned name.
Rhino.ObjectsByName (strName [, blnSelect [, intType]])
strName |
Required. String. The name of an object or objects. |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
blnSelect |
Optional. Boolean. Select the objects. If omitted, the objects are not selected (False). |
||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
intType |
Optional. Number. The type(s) of geometry objects (points, curves, surfaces, meshes, etc.) that can be returned. Object types can be added together to filter several different kinds of geometry.
|
Array |
An array of strings identifying the objects if successful. |
Null |
If not successful, or on error. |
Dim arrObjects, strName
strName = Rhino.GetString("Name to select")
If Not IsNull(strName) Then
arrObjects = Rhino.ObjectsByName(strName, True)
End If