IsRevSurface

Verifies an object is a surface of revolution.

Syntax

Rhino.IsRevSurface (strObject)

Parameters

strObject

Required.  String.  The identifier of the object to verify.

Returns

Boolean

True or False indicating success or failure.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a surface")

If Rhino.IsRevSurface(strObject) Then

  Rhino.Print "The object is a surface of revolution."

Else

  Rhino.Print "The object is not a surface of revolution."

End If

Also See

IsBrep

IsExtrusion

IsNurbsSurface

IsPlaneSurface

IsPolysurface

IsSumSurface

IsSurface