IsSumSurface

Verifies an object is a sum, or extruded, surface. Note, a sum surface is not a lightweight extrusion object.

Syntax

Rhino.IsSumSurface (strObject)

Parameters

strObject

Required.  String.  The identifier of the object to verify.

Returns

Boolean

True or False indicating success or failure.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a surface")

If Rhino.IsSumSurface(strObject) Then

  Rhino.Print "The object is a sum surface."

Else

  Rhino.Print "The object is not a sum surface."

End If

Also See

IsBrep

IsExtrusion

IsNurbsSurface

IsPlaneSurface

IsPolysurface

IsRevSurface

IsSurface