IsNurbsSurface

Verifies an object is a NURBS surface.

Syntax

Rhino.IsNurbsSurface (strObject)

Parameters

strObject

Required.  String.  The identifier of the object to verify.

Returns

Boolean

True or False indicating success or failure.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject("Select a surface")

If Rhino.IsNurbsSurface(strObject) Then

  Rhino.Print "The object is a NURBS curve."

Else

  Rhino.Print "The object is not a NURBS surface."

End If

Also See

IsBrep

IsExtrusion

IsPlaneSurface

IsPolysurface

IsRevSurface

IsSumSurface

IsSurface