Click or drag to resize

GH_RhinoScriptInterfaceSaveDocument Method

Save the currently active Grasshopper document. If the active document has never been saved, a Save... dialog will be shown. If there is no active document, nothing will happen.

Namespace:  Grasshopper.Plugin
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public bool SaveDocument()

Return Value

Type: Boolean
True on success, false on failure.
Examples
VBScript
Call GrasshopperExampleScript()
Sub GrasshopperExampleScript()
  Dim GH 
  Set GH = Rhino.GetPlugInObject("Grasshopper")
  Call GH.SaveDocument()
  Set GH = Nothing
End Sub
See Also