MaelstromObject

Deforms objects in a spiral as if they were caught in a whirlpool.

Syntax

Rhino.MaelstromObject (strObject, arrPlane, dblRadius0, dblRadius1, dblAngle [, blnCopy])

Rhino.MaelstromObject (strObject, arrPlane, dblRadius0, dblRadius1, dblAngle [, blnCopy])

Parameters

strObject

Required. String. The identifier of the object to deform.

arrObjects

Required. Array. An array of strings identifying the objects to deform.

arrPlane

Required. Array. The plane on which the base circle will lie. The origin of the plane will be the center point of the circle.

dblRadius0

Required. Number. The first radius.

dblRadius1

Required. Number. The second radius.

dblAngle

Required.  Number.  The coil angle in degrees.

blnCopy

Optional. Boolean. Copy the object. If omitted, the object(s) will not be copied (False).

Returns

String

The identifier of the deformed object if successful.

Array

An array of strings identifying the deformed objects if successful.

Null

If not successful, or on error.

Example

Dim arrObjects, arrBBox, arrStart, arrPlane, dblDiameter

arrObjects = Rhino.GetObjects("Select object to maelstrom")

If IsArray(arrObjects) Then

  arrBBox = Rhino.BoundingBox(arrObjects)

  arrStart = Rhino.PointDivide(Rhino.PointAdd(arrBBox(0), arrBBox(6)), 2)

  arrPlane = Rhino.MovePlane(Rhino.ViewCPlane, arrStart)

  dblDiameter = Rhino.Distance(arrBBox(0), arrBBox(6))

  Rhino.MaelstromObject arrObjects, arrPlane, dblDiameter/4, dblDiameter/2, 45, False

End If

Also See

BendObject

BoxMorphObject

FlowObject

SporphObject

StretchObject

TaperObject

TwistObject