SporphObject

Deforms an object from a source surface to a target surface.

Syntax

Rhino.SporphObject (strObject, strSurface0, strSurface1 [, arrParam0 [, arrParam1 [, blnCopy]]])

Rhino.SporphObject (arrObjects, strSurface0, strSurface1 [, arrParam0 [, arrParam1 [, blnCopy]]])

Parameters

strObject

Required. String. The identifier of the object to deform.

arrObjects

Required. Array. An array of strings identifying the objects to deform.

strSurface0

Required. String. The identifier of the base surface.

strSurface1

Required. String. The identifier of the target surface.

arrParam0

Optional. Array. The u,v parameter on strSurface0 used for orienting the surface.

arrParam1

Optional. Array. The u,v parameter on strSurface1 used for orienting the surface.

blnCopy

Optional. Array. Copy the object. If omitted, the object(s) will not be copied (False).

Returns

String

The identifier of the deformed object if successful.

Array

An array of strings identifying the deformed objects if successful.

Null

If not successful, or on error.

Example

Dim strObject, strSurface0, strSurface1

strObject = Rhino.GetObject("Select object to sporph")

If Not IsNull(strObject) Then

  strSurface0 = Rhino.GetObject("Base surface", 8)

  strSurface1 = Rhino.GetObject("Target surface", 8)

  Rhino.SporphObject strObject, strSurface0, strSurface1, , , False

End If

Also See

BendObject

BoxMorphObject

FlowObject

MaelstromObject

StretchObject

TaperObject

TwistObject