TwistObject

Deforms objects by rotating them around an axis.

Syntax

Rhino.TwistObject (strObject, arrStartPoint, arrEndPoint, dblAngle, [, blnInfinite [, blnCopy]])

Rhino.TwistObject (arrObjects, arrStartPoint, arrEndPoint, dblAngle, [, blnInfinite [, blnCopy]])

Parameters

strObject

Required. String. The identifier of the object to deform.

arrObjects

Required. Array. An array of strings identifying the objects to deform.

arrStartPoint

Required. Array. The starting point of the rotation axis.

arrEndPoint

Required. Array. The ending point of the rotation axis.

dlbAngle

Required. Number. The rotation angle in degrees.

blnInfinite

Optional.  Boolean.  If False (Default), then the twisting is not constant throughout the object. The deformation takes place only the length of the axis. The length of the axis is important. If the axis is shorter than the object, the twist applies only to that part of the object. If True, then the deformation is constant throughout the object, even if the axis is shorter than the object.

blnCopy

Optional. Boolean. Copy the object. If omitted, the object(s) will not be copied (False).

Returns

String

The identifier of the deformed object if successful.

Array

An array of strings identifying the deformed objects if successful.

Null

If not successful, or on error.

Example

Dim strObject, arrBox, arrPoint

strObject = Rhino.GetObject("Select object to twist")

If Not IsNull(strObject) Then

  Rhino.TwistObject strObject, Array(0,0,0), Array(1,0,0), 45, True, False

End If

Also See

BendObject

BoxMorphObject

FlowObject

MaelstromObject

SporphObject

StretchObject

TaperObject