TaperObject

Deforms objects toward or away from a specified axis.

Syntax

Rhino.TaperObject (strObject, arrStartPoint, arrEndPoint, dblStartRadius, dblEndRadius, [, blnFlat [, blnInfinite [, blnCopy]]])

Rhino.TaperObject (arrObjects, arrStartPoint, arrEndPoint, dblStartRadius, dblEndRadius, [, blnFlat [, blnInfinite [, blnCopy]]])

Parameters

strObject

Required. String. The identifier of the object to deform.

arrObjects

Required. Array. An array of strings identifying the objects to deform.

arrStartPoint

Required. Array. The starting point of an axis line to taper the objects around.

arrEndPoint

Required. Array. The ending point of an axis line to taper the objects around.

dblStartRadius

Required. Number. The radius at the start point.

dblEndRadius

Required. Number. The radius at the end point.

blnFlat

Optional. Boolean. If True, then a one-directional, one-dimensional taper is created. The default is False.

blnInfinite

Optional. Boolean. If False (Default), the deformation takes place only the length of the axis.  If True, the deformation happens throughout the object, even if the axis is shorter.

blnCopy

Optional. Boolean. Copy the object. If omitted, the object(s) will not be copied (False).

Returns

String

The identifier of the deformed object if successful.

Array

An array of strings identifying the deformed objects if successful.

Null

If not successful, or on error.

Example

Dim strObject, arrStart, arrEnd

strObject = Rhino.GetObject("Select object to taper")

If Not IsNull(strObject) Then

  arrStart = Rhino.GetPoint("Start of taper axis")

  arrEnd = Rhino.GetPoint("End of taper axis", arrStart)

  Rhino.TaperObject strObject, arrStart, arrEnd, 1.0, 2.0, , , False

End If

Also See

BendObject

BoxMorphObject

FlowObject

MaelstromObject

SporphObject

StretchObject

TwistObject