Copy of IRhRdkLinearWorkflow - eventually these classes need to be combined.
More...
#include <rhinoSdkDisplayPipelineAttributes.h>
Copy of IRhRdkLinearWorkflow - eventually these classes need to be combined.
◆ ComputeCRC()
ON__UINT32 CDisplayPipelineAttributes::LinearWorkflow::ComputeCRC |
( |
| ) |
const |
◆ GammaAdjustmentForPostProcessingFrameBuffer()
float CDisplayPipelineAttributes::LinearWorkflow::GammaAdjustmentForPostProcessingFrameBuffer |
( |
| ) |
const |
Use this function to determine the gamma correction factor for rendered output pixels. This will return the reciprocal value - not the UI value. Use this value in the pow function directly. Will return 1.f if PostProcessFrameBuffer returns false
◆ GammaAdjustmentForPreProcessingColors()
float CDisplayPipelineAttributes::LinearWorkflow::GammaAdjustmentForPreProcessingColors |
( |
| ) |
const |
Use this function to determine the gamma correction factor for input non-linear colors. Will return 1.f if PreProcessColors returns false
◆ GammaAdjustmentForPreProcessingTextures()
float CDisplayPipelineAttributes::LinearWorkflow::GammaAdjustmentForPreProcessingTextures |
( |
| ) |
const |
Use this function to determine the gamma correction factor for input non-linear textures. Will return 1.f if PreProcessTextures returns false
◆ IsEqual()
bool CDisplayPipelineAttributes::LinearWorkflow::IsEqual |
( |
const LinearWorkflow & |
| ) |
const |
◆ PostProcessFrameBuffer()
bool CDisplayPipelineAttributes::LinearWorkflow::PostProcessFrameBuffer |
( |
| ) |
const |
◆ PostProcessFrameBufferOn()
bool CDisplayPipelineAttributes::LinearWorkflow::PostProcessFrameBufferOn |
( |
| ) |
const |
◆ PostProcessGamma()
float CDisplayPipelineAttributes::LinearWorkflow::PostProcessGamma |
( |
| ) |
const |
◆ PostProcessGammaOn()
bool CDisplayPipelineAttributes::LinearWorkflow::PostProcessGammaOn |
( |
void |
| ) |
const |
◆ PreProcessColors()
bool CDisplayPipelineAttributes::LinearWorkflow::PreProcessColors |
( |
| ) |
const |
◆ PreProcessColorsOn()
bool CDisplayPipelineAttributes::LinearWorkflow::PreProcessColorsOn |
( |
| ) |
const |
◆ PreProcessGamma()
float CDisplayPipelineAttributes::LinearWorkflow::PreProcessGamma |
( |
| ) |
const |
◆ PreProcessTextures()
bool CDisplayPipelineAttributes::LinearWorkflow::PreProcessTextures |
( |
| ) |
const |
◆ PreProcessTexturesOn()
bool CDisplayPipelineAttributes::LinearWorkflow::PreProcessTexturesOn |
( |
| ) |
const |
◆ SetPostProcessFrameBuffer()
void CDisplayPipelineAttributes::LinearWorkflow::SetPostProcessFrameBuffer |
( |
bool |
| ) |
|
◆ SetPostProcessFrameBufferOn()
void CDisplayPipelineAttributes::LinearWorkflow::SetPostProcessFrameBufferOn |
( |
bool |
| ) |
|
◆ SetPostProcessGamma()
void CDisplayPipelineAttributes::LinearWorkflow::SetPostProcessGamma |
( |
float |
| ) |
|
◆ SetPostProcessGammaOn()
void CDisplayPipelineAttributes::LinearWorkflow::SetPostProcessGammaOn |
( |
bool |
bOn | ) |
|
◆ SetPreProcessColors()
void CDisplayPipelineAttributes::LinearWorkflow::SetPreProcessColors |
( |
bool |
| ) |
|
◆ SetPreProcessColorsOn()
void CDisplayPipelineAttributes::LinearWorkflow::SetPreProcessColorsOn |
( |
bool |
| ) |
|
◆ SetPreProcessGamma()
void CDisplayPipelineAttributes::LinearWorkflow::SetPreProcessGamma |
( |
float |
| ) |
|
◆ SetPreProcessTextures()
void CDisplayPipelineAttributes::LinearWorkflow::SetPreProcessTextures |
( |
bool |
| ) |
|
◆ SetPreProcessTexturesOn()
void CDisplayPipelineAttributes::LinearWorkflow::SetPreProcessTexturesOn |
( |
bool |
| ) |
|