Rhino C++ API
8.13
|
#include <RhRdkAutomaticUI.h>
Public Member Functions | |
CRhRdkParamTransport () | |
virtual | ~CRhRdkParamTransport () |
virtual void | DeleteThis (void) override |
virtual IRhRdkParamBlock & | ParamBlock (void) const override |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Public Member Functions inherited from IRhRdkParamTransportEx | |
virtual void | ParamBlockFromData (void) const =0 |
virtual void | ParamBlockToData (void) const =0 |
virtual CRhinoDoc * | RhinoDocForUndo (void) const =0 |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
Helper class to make it easier to implement IRhRdkParamTransportEx. This automatically manages the param block requirement. If you derive your parameter transport from this class (recommended) then you won't have to implement the ParamBlock() method.
CRhRdkParamTransport::CRhRdkParamTransport | ( | ) |
|
virtual |
|
overridevirtual |
You must implement this method as 'delete this'.
Implements IRhRdkParamTransportEx.
|
overridevirtual |
Implements IRhRdkParamTransportEx.