Rhino C++ API  8.13
Public Member Functions | List of all members
IRhRdkParamTransportEx Class Referenceabstract

#include <RhRdkAutomaticUI.h>

Inheritance diagram for IRhRdkParamTransportEx:
CRhRdkParamTransport

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual IRhRdkParamBlockParamBlock (void) const =0
 
virtual void ParamBlockFromData (void) const =0
 
virtual void ParamBlockToData (void) const =0
 
virtual CRhinoDocRhinoDocForUndo (void) const =0
 

Detailed Description

The RDK provides automatic user interface services that allow the user to manipulate arbitrary sets of named parameters which can be stored inside your RDK plug-in. The RDK accesses the parameters by means of the IRhRdkParamBlock interface.

See also
IRhRdkParamBlock

When using the 'raw' automatic UI, it's necessary to implement the IRhRdkParamTransportEx interface in order to transfer your parameters to and from the param block. Instead of implementing IRhRdkParamTransportEx directly it's recommended that you use CRhRdkParamTransport as a base class so you will not have to worry about managing the param block object.

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkParamTransportEx::DeleteThis ( void  )
pure virtual

You must implement this method as 'delete this'.

Implemented in CRhRdkParamTransport.

◆ ParamBlock()

virtual IRhRdkParamBlock& IRhRdkParamTransportEx::ParamBlock ( void  ) const
pure virtual
Returns
the param block.

Implemented in CRhRdkParamTransport.

◆ ParamBlockFromData()

virtual void IRhRdkParamTransportEx::ParamBlockFromData ( void  ) const
pure virtual

Populate the param block from the underlying data. Note that the param block is always cleared before this is called so you must always add the parameters each time this is called.

◆ ParamBlockToData()

virtual void IRhRdkParamTransportEx::ParamBlockToData ( void  ) const
pure virtual

Update the underlying data from the param block, recording undo if required.

◆ RhinoDocForUndo()

virtual CRhinoDoc* IRhRdkParamTransportEx::RhinoDocForUndo ( void  ) const
pure virtual

Get the document to use for recording undo. If your param transport supports undo, this method should return the document in which to record the undo. The framework will create the necessary undo record but you will be responsible for handling the undo in your implementation of ParamBlockToData().