Rhino C++ API
8.13
|
#include <RhRdkPostEffectPlugInManager.h>
Public Member Functions | |
CRhRdkPostEffectPlugInManager () | |
virtual | ~CRhRdkPostEffectPlugInManager () |
bool | AllowWireframeEffects (void) const |
virtual_su bool | CanDisplayOptions (const UUID &uuidPlugIn) const |
virtual bool | DisplayOptions (const UUID &uuidPlugIn, HWND hParent) const |
virtual bool | EnablePlugIn (const UUID &uuidPlugIn, bool bEnable=true) const |
CImpl & | GetImpl (void) const |
virtual bool | GetNextPlugIn (UUID &uuidOut, ON_wString &sNameOut) const |
virtual IRhRdkPostEffectImage * | Image (void) const |
virtual bool | Initialize (IRhRdkPostEffectImage *pImage) const |
virtual bool | IsPlugInEnabled (const UUID &uuidPlugIn) const |
virtual bool | MoveDown (const UUID &uuidPlugIn) const |
virtual bool | MoveDownPossible (const UUID &uuidPlugIn) const |
virtual bool | MoveUp (const UUID &uuidPlugIn) const |
virtual bool | MoveUpPossible (const UUID &uuidPlugIn) const |
const CRhRdkPostEffectPlugInManager & | operator= (const CRhRdkPostEffectPlugInManager &srce) |
virtual CRhRdkPostEffectPlugIn * | PlugIn (const UUID &uuidPlugIn) const |
virtual bool | PlugInWorksWithCurrentImage (const UUID &uuidPlugIn) const |
virtual bool | ProcessImage (void) const |
virtual bool | ReadState (const UUID &uuidPlugIn, const void *pBuffer, size_t size) const |
virtual void | ResetPlugInIterator (void) const |
virtual bool | RunSingleProcess (const UUID &uuidPlugIn) const |
void | SetAllowWireframeEffects (bool bAllow) |
virtual void | SetAllPlugInsToDocumentDefaults (const CRhinoDoc &doc) const |
virtual RDK_DEPRECATED void | SetAllPlugInsToDocumentDefaults (void) const |
virtual void | SetAllPlugInsToFactoryDefaults (void) const |
virtual DWORD | StateCRC (void) const |
virtual void | WriteAllPlugInsToDocumentDefaults (CRhinoDoc &doc) const |
virtual RDK_DEPRECATED void | WriteAllPlugInsToDocumentDefaults (void) const |
virtual bool | WriteState (const UUID &uuidPlugIn, void *pBuffer, size_t &size) const |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Protected Attributes | |
CImpl * | m_pImpl |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
CRhRdkPostEffectPlugInManager::CRhRdkPostEffectPlugInManager | ( | ) |
|
virtual |
bool CRhRdkPostEffectPlugInManager::AllowWireframeEffects | ( | void | ) | const |
virtual_su bool CRhRdkPostEffectPlugInManager::CanDisplayOptions | ( | const UUID & | uuidPlugIn | ) | const |
Query if a plug-in can display a properties dialog.
uuidPlugIn | is the UUID of the plug-in. |
|
virtual |
Display plug-in options to the user.
uuidPlugIn | is the UUID of the plug-in. |
|
virtual |
Enable a plug-in.
uuidPlugIn | is the UUID of the plug-in. |
CImpl& CRhRdkPostEffectPlugInManager::GetImpl | ( | void | ) | const |
|
virtual |
Get the next plug-in.
uuidOut | accepts the UUID of the next plug-in. |
sNameOut | accepts the name of the next plug-in. |
|
virtual |
|
virtual |
Initialize the manager.
pImage | is a pointer to a post-effect image that will be modified by the plug-ins. This pointer can be NUILL in which case RunSingleProcess() will have no effect. |
|
virtual |
Query if a plug-in is enabled.
uuidPlugIn | is the UUID of the plug-in. |
|
virtual |
Move a plug-in down in the list.
uuidPlugIn | is the UUID of the plug-in to move. |
|
virtual |
uuidPlugIn | is the UUID of the plug-in. |
|
virtual |
Move a plug-in up in the list.
uuidPlugIn | is the UUID of the plug-in to move. |
|
virtual |
uuidPlugIn | is the UUID of the plug-in. |
const CRhRdkPostEffectPlugInManager& CRhRdkPostEffectPlugInManager::operator= | ( | const CRhRdkPostEffectPlugInManager & | srce | ) |
Copy the manager.
|
virtual |
Find a plug-in by its UUID.
uuidPlugIn | is the UUID of the plug-in to find. |
|
virtual |
uuidPlugIn | is the UUID of the plug-in. |
|
virtual |
Process the image by calling RunSingleProcess() on each enabled plug-in in order, stopping if any one plug-in fails.
|
virtual |
Read a plug-in's state from a buffer.
uuidPlugIn | is the UUID of the plug-in. |
pBuffer | is the buffer containing data previously written by WriteState(). |
size | is the number of bytes in the buffer. |
|
virtual |
Reset the iterator for GetNextPlugIn().
|
virtual |
Process the image with a single plug-in.
uuidPlugIn | is the UUID of the plug-in. |
void CRhRdkPostEffectPlugInManager::SetAllowWireframeEffects | ( | bool | bAllow | ) |
|
virtual |
Reset all post-effect plug-ins to document defaults.
|
virtual |
This method is deprecated in favor of the one below.
|
virtual |
Reset all post-effect plug-ins to their original factory defaults.
|
virtual |
Get the CRC of all plug-in state.
|
virtual |
Copy all post-effect plug-in state to document defaults.
|
virtual |
This method is deprecated in favor of the one below.
|
virtual |
Write a plug-in's state to a buffer.
uuidPlugIn | is the UUID of the plug-in. |
pBuffer | is the buffer to fill with state information. |
size | is the physical number of bytes that the buffer can accomodate. This parameter also accepts the logical number of bytes written to the buffer. This will be more than size if the buffer was not big enough. If pBuffer is NULL you can pass zero in size to get the number of bytes required to write the plug-in state. |
|
protected |