Rhino C++ API
8.13
|
#include <RhRdkSdkRender.h>
Public Member Functions | |
CRhRdkRenderMesh () | |
virtual | ~CRhRdkRenderMesh () |
virtual const CRhRdkObjectAncestry * | Ancestry (void) const |
virtual ON_BoundingBox | BoundingBox (void) const |
virtual bool | Box (ON_PlaneSurface &plane, ON_Interval &z_interval) const |
virtual void | Clear (void) |
virtual bool | Cone (ON_Cone &cone, ON_Plane &truncation) const |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
virtual bool | IsONMaterial (void) const |
virtual bool | IsRdkMaterial (void) const |
virtual const ON_Mesh * | Mesh (void) const |
virtual_su std::shared_ptr< const ON_Mesh > | MeshEx (void) const |
virtual const CRhinoObject * | Object (void) const |
virtual const ON_Material * | ONMaterial (void) const |
virtual bool | Plane (ON_PlaneSurface &plane) const |
enum RhRdkRenderMeshPrimitiveTypes | PrimitiveType (void) const |
virtual const CRhRdkMaterial * | RdkMaterial (void) const |
virtual_su std::shared_ptr< const CRhRdkMaterial > | RdkMaterialEx (void) const |
virtual void | SetAncestry (const CRhRdkObjectAncestry &rma) |
virtual void | SetBox (const ON_PlaneSurface &plane, const ON_Interval &z_interval) |
virtual void | SetCone (const ON_Cone &cone, const ON_Plane &plane) |
virtual void | SetGeometry (const CRhRdkCustomRenderMeshes &crm, int iIndex) |
virtual_su void | SetGeometryEx (const IRhRdkCustomRenderMeshes &crm, int iIndex) |
virtual_su void | SetGeometryEx (const RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance &instance) |
virtual void | SetMesh (const ON_Mesh *pMesh) |
void | SetMesh (std::shared_ptr< const ON_Mesh > pMesh) |
virtual void | SetObject (const CRhinoObject *pObject) |
virtual void | SetONMaterial (const ON_Material *pONMaterial) |
virtual void | SetPlane (const ON_PlaneSurface &plane) |
virtual void | SetRdkMaterial (const CRhRdkMaterial *pRdkMaterial) |
virtual_su void | SetRdkMaterial (std::shared_ptr< const CRhRdkMaterial > pRdkMaterial) |
virtual void | SetSphere (const ON_Sphere &sphere) |
virtual void | SetXformInstance (const ON_Xform &xform) |
virtual const ON_Sphere * | Sphere (void) const |
virtual ON_Xform | XformInstance (void) const |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
CRhRdkRenderMesh::CRhRdkRenderMesh | ( | ) |
|
virtual |
|
virtual |
|
virtual |
|
virtual |
|
virtual |
|
virtual |
Emergency virtual function for future expansion.
Reimplemented from CRhRdkObject.
|
virtual |
|
virtual |
|
virtual |
virtual_su std::shared_ptr<const ON_Mesh> CRhRdkRenderMesh::MeshEx | ( | void | ) | const |
|
virtual |
|
virtual |
|
virtual |
|
strong |
|
virtual |
virtual_su std::shared_ptr<const CRhRdkMaterial> CRhRdkRenderMesh::RdkMaterialEx | ( | void | ) | const |
|
virtual |
|
virtual |
|
virtual |
virtual_su void CRhRdkRenderMesh::SetGeometryEx | ( | const IRhRdkCustomRenderMeshes & | crm, |
int | iIndex | ||
) |
virtual_su void CRhRdkRenderMesh::SetGeometryEx | ( | const RhRdk::CustomRenderMeshes::IRenderMeshes::IInstance & | instance | ) |
|
virtual |
void CRhRdkRenderMesh::SetMesh | ( | std::shared_ptr< const ON_Mesh > | pMesh | ) |
|
virtual |
|
virtual |
|
virtual |
|
virtual |
virtual_su void CRhRdkRenderMesh::SetRdkMaterial | ( | std::shared_ptr< const CRhRdkMaterial > | pRdkMaterial | ) |
|
virtual |
|
virtual |
|
virtual |
|
virtual |